Cerca con Google

Translate

16 marzo 2012

La fase di test è finita! App Inventor prosegue la sua marcia!


Come annunciato da Hal in questo post:

http://groups.google.com/group/mit-appinventor-testers/browse_thread/thread/9744108af43e6cb2

La fase di test (quella a numero chiuso) è stata dichiarata ufficialmente chiusa e quindi verranno chiusi anche i forum di supporto creati appositamente, si invitano gli utenti ad utilizzare da ora in avanti il bug tracker ufficiale che trovate a questa pagina:

http://code.google.com/p/app-inventor-for-android/wiki/ReportingBugs

dove andranno segnalati tutti i bug riscontrati.

Hal esprime la sua soddisfazione visto che la fase Beta di App Inventor è partita addirittura con un mese di anticipo rispetto ai tempi previsti, ricordo ancora una volta che il nuovo sito è raggiungibile all'indirizzo:

http://appinventor.mit.edu/ 


Per usare App Inventor non dovete aver altro che un account google e cliccare sulla parte destra dello schermo dove dice "Use MIT App Inventor"

I nuovi forum di supporto dove potete fare tutte le vostre domande (in inglese) e leggere tante interessanti informazioni li trovate a questo indirizzo:


Per quanto mi riguarda sono finalmente riuscito a trovare il tempo per registrare un nuovo videotutorial (sul multiscreen) che conto di pubblicare al più presto, scusatemi se mi troverete un pò "arrugginito" ma in effetti non lavorandoci più assiduamente come prima ho perso un pò il "feeling"...
a presto allora, e come sempre, se avete dei suggerimenti su dei tutorial che volete che tratti fatemelo sapere e vedrò di fare il possibile per soddisfare le vostre richieste :) 

15 commenti:

  1. Ciao Sebastiano hai notizie sul se e quando sarà possibile lavorare con app inventor in locale anche per gli utenti windows ? Grazie

    RispondiElimina
    Risposte
    1. Purtroppo non so niente ma comunque secondo me non è una priorità per il team che sta seguendo lo sviluppo di app inventor
      ad ogni modo dovessi scoprire qualcosa sarai il primo ad esserne informato

      Elimina
    2. Ti ringrazio...ho problemi quando sono grandi i progetti...credo molto dipenda anche dalla velocità della adsl, quando lavoro con una 20 mega vado alla grande con una 7 mega invece il tempo è 4 volte se non di piu in meno della 20...però con il pc con il quale lavoro con la 20 spesso i grossi progetti il block editor non riesce ad aprirli forse perchè la scheda grafica non è potente....in poche parole ho un grosso progetto ma per portarlo avanti ci vuole molta molta pazienza....

      Elimina
    3. Se vedi nelle limitazioni dichiarate ci sono problemi quando i progetti sono troppo grosdi,forse e' questo il tuo problema,io credo che un ADSL 7mega sia più che sufficiente,speriamo velocizzino ai con le prossime release

      Elimina
    4. Ciao Sebastiano, dopo vari sbattimenti per risolvere il problema di continuare a lavorare sulla mia app iventata troppo grande credi di aver risolto almeno per ora. Cerco di esporre i problemi da me incontrati sperando che possano essere di aiuto a qualcuno. Lavorando sia con vista che con xp con sistemi operativi a 32bit con 4 giga di ram ma di cui ne venivano letti poco piu di 3 per via delle limitazioni dei sistemi operativi a 32bit, quando tentavo di aprire la mia app si presentavano diversi problemi quali visualizzazione del block editor rovinata per via di java che necessitava di piu memoria
      o problemi di scrittura nel block editor (inserivo gli oggetti ma sparivano). Ho risolto lavorando con win 7 pro 64 bit e 4 giga di ram che venivano letti tutti. Io ho una scheda video da 256 dedicata . Inoltre in ogni caso consiglio di installare java 7 che consente di lavorare in modo piu veloce nel block editor e dovrebbe gestire meglio la memoria....saluti Enzo

      Elimina
    5. Grazie Enzo! come sempre i tuoi suggerimenti sono preziosi:)
      come avrai visto per i miei tutorial i progetti che realizzo sono molto semplici (pensa che giro i tutorial su una virtual machine dedicata con 512Mb di Ram appena :) )
      Ovviamente si necessitasse di più memoria meglio andare su un s.o a 64bit che vede tutta la ram installata nel sistema! grazie ancora e se hai voglia, rendici partecipi dei tuoi progetti! :)

      Elimina
    6. Grazie a te per questo spazio che ha dato l'input a tanti...appena sarà pronto la mia prossima app sperando di non trovare altri ostacoli, te la mando...a presto (speriamo)....Enzo.

      Elimina
  2. Ciao Sebastiano
    Sai dirmi perchè su un tablet ideos android 2.2 nelle app vedo i banner publicitari e su un htc nexus 2.3.6 nella stessa app non si vedono i banner? e non si vedono neppure navigando normalmente sul browser

    RispondiElimina
    Risposte
    1. Hai conrollato l'user agent che invia il browser,quel tipo di banner esce solo se impostato su mobile...

      Elimina
    2. Perdona l'ignoranza ma non so come si verifica l'user agenti!
      Adesso ti sto scrivendo dal nexus e sul tuo bluff non vedo banner :-(

      Elimina
    3. Perdona l'ignoranza ma non so come si verifica l'user agenti!
      Adesso ti sto scrivendo dal nexus e sul tuo bluff non vedo banner :-(

      Elimina
    4. Non e' che per caso hai una rom custom con adblock attivo,controlla su www.whatsmyuseragent.com

      Elimina
  3. ciao sebastiano
    dopo aver testato una semplice app e vederla funzionare bene sull'emulatore, vado a scaricare l'apk e la installo sul telefono.
    fin qui tutto bene non appena la lancio e provo le varie opzioni mi genera degli errori che non mi risultano sull'emulatore.. sai dirmi come mai?

    RispondiElimina
    Risposte
    1. Fabio a me è capitata la stessa cosa quando ho installato la mia app su un tablet con una versione android vecchiotta , credo (anche se è sempre da vedere il tipo di errore) che possa essere dovuto al fatto che alcune funzioni non vengono lette bene da vecchie versioni android e va in errore....

      Elimina